ihaskell-docker/kernels.nix
2023-04-19 06:23:43 +02:00

35 lines
661 B
Nix

{pkgs, ...}: {
kernel.python.python = {
enable = true;
displayName = "Python 3";
extraPackages = ps: with ps; [
];
};
kernel.haskell.haskell = {
enable = true;
displayName = "GHC 9.0.2";
haskellCompiler = "ghc902";
extraHaskellPackages = ps: with ps; [
hvega
formatting
ihaskell-charts
ihaskell-diagrams
ihaskell-gnuplot
ihaskell-graphviz
ihaskell-hvega
ihaskell-juicypixels
ihaskell-magic
ihaskell-plot
hmatrix
cassava
attoparsec
safe-exceptions
conduit
conduit-extra
text_2_0_1
bytestring_0_11_3_1
];
};
}